Product Description Tab: Device Compatibility


No Boxes, No Routers, No WIFI required. 

All you need is your ilumi and the free ilumi app downloaded to your mobile device. Here are devices known to be compatible with the ilumi LED Smartbulbs.

Apple Devices

Requires devices with Bluetooth 4.0/Bluetooth Smart running iOS 8.0+


  • iPhone 4S, iPhone 5, iPhone 5s, iPhone 5c, iPhone 6 and iPhone 6 Plus
  • iPad 3rd Gen, iPad 4th Gen, and iPad Air
  • iPad Mini and iPad Mini Retina
  • iPod 5th Gen

 Download the free ilumi app on iOS iTunes


To find the ilumi iOS app on your device, simply search "ilumi" and download the app. For iPad users, you'll need to search for "iPhone Apps only".


As Apple releases new versions of iOS, please ensure your device is updated to the latest version. There can be changes to the operating system that affect Bluetooth connectivity, so it's always best to stay up-to-date and be informed of how OS updates will affect your device. 


Android Devices

Requires devices with Bluetooth 4.0/Bluetooth Smart

Works best with Android 5.0+


  • Samsung Galaxy S3, S4, and S5
  • Samsung Galaxy Note II and III
  • Google Nexus 4, 5, and 7-2nd Gen only
  • Other Android devices may be compatible - please check the Google Play to verify your device is compatible with the ilumi app. If you're using an unsupported device, it's possible that the app will not display in the search results or you will receive a message that your device is unsupported.

Download the free ilumi app on iOS iTunes


ilumi may work with devices on Android OS 4.3 or higher, but as Google releases new versions of Android, ilumi will be unable to continue to support older versions of Android. 


Periodically, Google may make changes in the Android operating system that affect Bluetooth connectivity, negatively or positively, so please reach out to if you are experiencing Bluetooth connectivity issues.


We highly recommend keeping your device updated to the latest possible iOS & Android OS for the best possible results.


Please note: As technology changes, we will make every effort to remain backwards compatible for as long as we can. As changes are made to your device's operating system, sometimes important and necessary changes are made that prevents ilumi from working at an optimal level on earlier versions. After careful review and testing, we may make the decision to change our minimum supported requirements. Please reach out to if you have any questions!